DJI App Mobile Phone Compatibility
  • computer
  • 21/11/2022
  • 28 Views

DJI App Mobile Phone Compatibility

DJI have 3 different apps for controlling drones via your smartphone or mobile device.

If your remote controller does not have a screen you will need to ensure your smartphone is compatible or you won't be able to fly.

This applies to the Mavic 3, Air 2S, Mini SE, Air 2 and Mavic series drones. This also applies to this DJI FPV, although it does not require an app to fly, you will need the app to activate it.

Remote controllers with screens, such as the DJI RC Pro, DJI Smart Controller and DJI Smart Controller Enterprise do not need a compatible phone as the apps are installed directly onto the remote.

Your drone user manual or packaging should tell you which app is the best for your drone. Different apps are compatible with different devices.

DJI Go and DJI Pilot have wider compatibility than the newer DJI Fly app. DJI Fly requires iOS 11.0 / Android 6.0 or higher, while DJI Pilot and the older DJI Go app are will be compatible with devices running iOS 10.0 / Android 5.0 and above.

When it comes to selecting which phone or tablet is the best for the latest DJI drones, we would always recommend the latest models.

More powerful devices and modern technology will always have their advantages when it comes to streaming high quality video while simultaneously transmitting data to and from your drone.

DJI Fly is the flight app for the newest consumer drones, and as such requires devices to be running the latest firmware - iOS 11.0 or Android 6.0 or higher.

DJI App Mobile Phone Compatibility

DJI Fly Apple device compatibility list

Requires iOS 11.0 or above.

DJI Fly Android Device compatibility list

Requires Android 6.0 or above.

DJI Go 4 is the app for older DJI drones, such as the Mavic series, Spark and Phantom 4.

DJI Go 4 requires devices to be running iOS 10.0 or Android 5.0 and above.

DJI Go 4 Apple Device compatibility list

Requires iOS 10.0 or above.

DJI Go 4 Android Device compatibility list

Requires Android 5.0 or above.

*Support for additional devices available as testing and development continues.

DJI Pilot is designed for use with Enterprise Drones, most notably the Mavic 2 Enterprise series.

DJI Pilot requires devices to be running iOS 10.0 / Android 5.0 or higher.

DJI Go 4 iOS Device compatibility list

Requires iOS 10.0 or above.

DJI Go 4 Android Device compatibility list

Requires Android 5.0 or above.

*Support for additional devices available as testing and development continues.

#
#
#
#
#
#